МАЙЕР Р.В.

ИСПОЛЬЗОВАНИЕ КОМПЬЮТЕРА ДЛЯ ИЗУЧЕНИЯ

РЕАКТИВНОГО ДВИЖЕНИЯ СЕГНЕРОВА КОЛЕСА

Предлагается экспериментальная установка для изучения реактивного движения. Она состоит из сегнерова колеса, на котором установлен диск с прорезями, а рядом расположен оптодатчик, подключеный к компьютеру. Компьютер измеряет скорость вращения и строит график ее зависимости от времени.

Универсальный измеритель времени на базе персонального компьютера может быть использован в различных опытах по механике [1], в том числе и для изучения движения тел переменной массы. Установка для изучения реактивного движения (рис.1) состоит из сегнерова колеса, выполненного в виде подвешенной на нити 1 длиной 0,5 м двухлитровой пластиковой бутылки 3 с двумя изогнутыми трубками 5 диаметром 3-5 мм. К крышке бутылки прикреплен диск 2 диаметром 200 мм, по краю которого выполнены 96 прорезей. Бутылка расположена над кюветой 4, в ее верхней части имеется отверстие для воздуха. Вблизи края диска находится оптодатчик, состоящий из лампочки накаливания 6 на 6,3 В и фотодиода 7, подсоединенного к формирователю счетных импульсов 8, который подключен к параллельному порту компьютера 9. Формирователь импульсов представляет собой усилитель, к выходу которого подключен триггер Шмидта. При вращении диска происходит периодическое освещение и затемнение фотодиода, в результате чего в компьютер поступают импульсы, обрабатываемые программой на Pascal или QBasic.

Питание датчика осуществляется от параллельного порта компьютера. Ниже представлена программа, написанная на языке Qbasic, которая в течение 2 с считает количество прорезей диска, прошедших через оптодатчик, и определяет скорость вращения. Результат записывается в файл data.txt, а на экране строится точка. После этого процесс повторяется снова. На экране компьютера получается график зависимости угловой скорости вращения колеса Сегнера от времени.

SCREEN 11                                 'ГРАФИЧЕСКИЙ РЕЖИМ
OUT &H378, 255                            'ПИТАНИЕ ДАТЧИКА
n$ = "data"                                   'НАЗВАНИЕ ФАЙЛА
OPEN n$ FOR OUTPUT AS #1  'ОТКРЫТИЕ  ФАЙЛА
vremya = 2: T0 = TIMER                    'ЗАДАНИЕ  ВРЕМЕНИ  СЧЕТА
LINE (0, 460)-(640, 460): LINE (10, 0)-(10, 480)   'ОСИ  КООРДИНАТ
WHILE INKEY$ = ""                    'ЦИКЛ 1 ДО НАЖАТИЯ  ПРОБЕЛА
dT = 0: T1 = TIMER: n = 0
WHILE dT < vremya                    'НАЧАЛО ЦИКЛА 2 СЧЕТА ОТВЕРСТИЙ
x = INP(&H379)                       'СЧИТЫВАНИЕ СОСТОЯНИЯ  ДАТЧИКА
WHILE x = 127: x = INP(&H379): WEND  'ФОТОДИОД  ЗАТЕМНЕН
WHILE x = 255: x = INP(&H379): WEND  'ФОТОДИОД  ОСВЕЩЕН
T2 = TIMER: dT = T2 - T1: n = n + 1  'N --ЧИСЛО  ОТВЕРСТИЙ
WEND                                           'КОНЕЦ  ЦИКЛА 2
w = n * (2 * 3.14 / 96) / vremya               'УГЛОВАЯ  СКОРОСТЬ
CIRCLE (10 + (T1 - T0) * 5, 460 - w * 50), 2   'ПОСТРОЕНИЕ  ТОЧЕК
PRINT #1, "Время"; T1 - T0; "Угловая скорость"; w  'ЗАПИСЬ В ФАЙЛ
WEND                                               'КОНЕЦ ЦИКЛА 1
CLOSE : END
Для выполнения измерений закрывают сопла сегнерова колеса пластилином и наполняют бутылку водой, после этого закручивают крышку с диском и подвешивают бутылку на нити. Запускают программу и открывают сопла, -- бутылка с диском начинает вращаться. На экране компьютера происходит построение графика зависимости модуля угловой скорости бутылки от времени (рис. 2). Сегнерово колесо сначала разгоняется, его скорость достигает максимума, после чего из-за сил трения и силы упругости нити оно останавливается, изменяет направление вращения и начинает совершать затухающие колебания.

Аналогичный эксперимент был проведен с другим колесом Сегнера, имеющим вид цилиндрического сосуда с двумя соплами, установленного на вертикальном заостренном стержне. Из графика на рис.3 видно, что скорость сегнерова колеса сначала возрастает, достигает максимума, а затем, когда вода почти вся вытекла, уменьшается до нуля вследствие действия тормозящего момента. Полученные результаты согласуются с результатами вычислительного эксперимента (рис.4), который был проведен с компьютерной моделью сегнерова колеса.

Литература

1. Матаев Г.Г. Компьютерная лаборатория в вузе и школе. Учебное пособие. -- М.: Горячая линия - Телеком, 2004. -- 440 c.