Coil: программа для расчета параметров и магнитного поля цилиндрического соленоида:
активное сопротивление, индуктивность, потребляемый ток, рассеиваемая мощность,
магнитная индукция в центре и в заданной точке пространства

На рисунке показан цилиндрический соленоид в разрезе.

Исходные данные:
R1 - внутренний радиус соленоида, м;
R2 - внешний радиус соленоида, м;
H - высота соленоида, м;
D - диаметр обмоточного провода без изоляции (для проводов прямоугольного сечения производится пересчет по формуле D=(4s/p)1/2, где s - площадь поперечного сечения провода, м2), м;
Lambda - фактор упаковки (отношение площади, занятой проводом в поперечном сечении соленоида без учета изоляции, к площади поперечного сечения соленоида) [7];
f - частота приложенного напряжения, Гц;
Ed - действующее значение приложенного напряжения, В;
x - радиус точки (относительно точки (0, 0)), в которой требуется рассчитать составляющие магнитной индукции, м;
z - высота точки (относительно точки (0, 0)), в которой требуется рассчитать составляющие магнитной индукции, м.

Расчетные данные:
R - активное сопротивление обмотки соленоида (условия нормальные), Ом;
L - индуктивность соленоида, Гн;
ZL - реактивное сопротивление соленоида, Ом
N - число витков;
Id - действующее значение тока через соленоид, А;
P - рассеиваемая в соленоиде мощность, Вт;
B0d - магнитная индукция (действующее значение) в центре соленоида (точка (0, 0)), Тл;
Bxd (x, z) - радиальная составляющая магнитной индукции (действующее значение) в точке с координатами (x, z) (относительно точки (0, 0)), Тл;
Bzd (x, z) - аксиальная составляющая магнитной индукции (действующее значение) в точке с координатами (x, z) (относительно точки (0, 0)), Тл.

Программа Coil позволяет расчитывать по заданным геометрическим размерам (R1, R2, H), диаметру провода D и фактору упаковки Lambda: активное сопротивление R (по меди), индуктивность L, число витков N, величину тока Id в обмотке при заданном напряжении Ed заданной частоты f, рассеиваемую при этом мощность P, реактивное сопротивление ZL, величину магнитной индукции (Bxd, Bzd) в заданной точке пространства (x, z), величину магнитной индукции B0 в центре соленоида (0, 0). Расчеты производятся в системе СИ. Результаты выводятся на экран монитора, а также при необходимости на принтер (в некоторых версиях программы).

DOS-версия программы Coil

Демонстрационная DOS-версия программы Coil: Coil_11d.rar (~16 Кбайт)

В демонстрационной DOS-версии программы Coil (Coil_11d) производится расчет сопротивления, индуктивности, числа витков. Результаты выводятся на экран монитора. DOS-версия предназначалась для работы с операционными системами MS-DOS и Windows 3.1, но может работать также с Windows 95, 98 и XP (с другими ОС не проверялась).

Файл Coil_11d.rar необходимо распаковать в заранее созданную папку. Упаковка производилась с помощью WinRar 2.80. Результат распаковки: Coil_11d.exe - исполняемый файл программы, Coil.ico - значок, который можно привязать к программе и поместить на рабочий стол. После запуска программы управление осуществляется с помощью клавиатуры (горячие клавиши, ввод цифровых данных). Исходные данные (R1 - внутренний радиус соленоида, R2 - внешний радиус соленоида, H - высота соленоида, D - диаметр обмоточного провода) необходимо вводить в метрах (разделителем для десятичной дроби служит точка, например, 0.005). Фактор упаковки Lambda может изменяться приблизительно от 0.5 для намотки круглым проводом внавал до 0.75 при намотке круглым проводом или шиной прямоугольного сечения виток к витку. Формат выходных данных экспоненциальный, например, 1.23456789012345E-0003 = 0.00123456789012345.

Для исходных данных:
R1 = 0.01 м (10 мм);
R2 = 0.02 м (20 мм);
H = 0.03 м (30 мм);
D = 0.001 м (1 мм);
Lambda = 0.6
расчетные данные должны быть:
N = 2.29183105468750E+0002 витков (~229 витков);
R = 4.59282875061035E-0001 Ом (~0.46 Ом);
L = 8.03295522928238E-0004 Гн (~0.8 мГн).

Windows-версия программы Coil

Демонстрационная Windows-версия программы Coil: Coil_20d.rar (~88 Кбайт)

В демонстрационной Windows-версии программы Coil (Coil_20d) производится расчет сопротивления, индуктивности, числа витков. Результаты выводятся на экран монитора. Windows-версия предназначалась для работы с операционными системами Windows 3.1, Windows 95, 98 и XP (с другими ОС не проверялась).

Файл Coil_20d.rar необходимо распаковать в заранее созданную папку. Упаковка производилась с помощью WinRar 2.80. Результат распаковки: Coil_20d.exe - исполняемый файл программы. После запуска программы можно вводить входные данные и производить расчет нажатием соответствующей кнопки. Исходные данные (R1 - внутренний радиус соленоида, R2 - внешний радиус соленоида, H - высота соленоида, D - диаметр обмоточного провода) необходимо вводить в метрах (учитывайте принятый в ОС формат разделителя для десятичной дроби: точка или запятая, например, 0.005 или 0,005; необходимо установить точку). Фактор упаковки Lambda может изменяться приблизительно от 0.5 для намотки круглым проводом внавал до 0.75 при намотке круглым проводом или шиной прямоугольного сечения виток к витку.

Для исходных данных:
R1 = 0.01 м (10 мм);
R2 = 0.02 м (20 мм);
H = 0.03 м (30 мм);
D = 0.001 м (1 мм);
Lambda = 0.6
расчетные данные должны быть:
N = 229.2 витков;
R = 0.4593 Ом;
L = 0.0008033 Гн.

С помощью программы Coil можно рассчитывать индукцию магнитного поля и параметры систем соленоидов, используя принцип суперпозиции [1] и различные методики [4].

Скопированные файлы могут быть проверены на отсутствие вирусного кода в режиме on-line [6] с помощью антивирусного пакета Лаборатории Касперского. Пакет содержит полный набор ежедневно обновляемых вирусных баз.

По вопросу получения полной версии программы обращайтесь к автору (см. раздел Контактная информация).

Ссылки:

  1. Законы и уравнения магнитного поля
  2. Иродов И. Е. Основные законы электромагнетизма: Учеб. пособие для студентов вузов. - 2-е, стереотип. - М.: Высш. шк., 1991. - 288 с.: ил.
  3. Калантаров П. Л., Цейтлин Л. А. Расчет индуктивностей: Справочная книга. - 3-е изд., перераб. и доп. Л.: Энергоатомиздат. Ленингр. отд-ние, 1986. - 488 с.: ил.
  4. Методика расчета индуктивности системы из двух соосных цилиндрических соленоидов
  5. Немцов М. В. Справочник по расчету параметров катушек индуктивности. - 2-е изд., перераб. и доп. - М.: Энергоатомиздат, 1989. - 192 с.: ил.
  6. Проверка файлов пользователя на наличие вирусного кода в режиме on-line
  7. Расчет фактора упаковки при намотке соленоидов

Словарь терминов:

  • Активное сопротивление - часть полного сопротивления контура, связанная с тепловыделением в контуре.
  • Индуктивность - величина, численно равная потоку самоиндукции контура при токе единичной силы.
  • Катушка индуктивности - электрический контур (цепь), специально предназначенный для создания собственного магнитного поля за счет протекающего по контуру тока.
  • Магнитная индукция - вектор, численно равный пределу отношения силы, действующей со стороны магнитного поля на элемент проводника с электрическим током, к произведению тока и длины элемента проводника, если длина этого элемента стремится к нулю, а элемент так расположен в поле, что этот предел имеет наибольшее значение, и направленный перпендикулярно к направлению элемента проводника и к направлению силы, действующей на этот элемент со стороны магнитного поля, причем из его конца вращение по кратчайшему расстоянию от направления силы к направлению тока в элементе проводника должно быть видно происходящим против часовой стрелки.
  • Поток самоиндукции контура - магнитный поток, создаваемый собственным магнитным полем тока в контуре, сквозь поверхность, ограниченную контуром.
  • Принцип суперпозиции магнитных полей - магнитное поле, создаваемое несколькими движущимися зарядами или токами, равно векторной сумме магнитных полей, создаваемых каждым зарядом или током в отдельности.
  • Реактивное сопротивление - часть полного сопротивления контура, не связанная с тепловыделением в контуре.
  • Соленоид (от греч. solen - трубка и eidos - вид) – осесимметричная катушка индуктивности.
  • Фактор упаковки (коэффициент заполнения) - отношение объема проводника к объему обмотки; при равномерной намотке равен отношению суммарной площади проводников в поперечном сечении обмотки (без учета изоляции) к площади поперечного сечения обмотки.
  • Цилиндрический соленоид - соленоид в виде цилиндра с центральным цилиндрическим отверстием (если таковое имеется).

20.05.2004
24.06.2004
16.07.2004
07.10.2005
17.04.2006
28.12.2006