Протонный магнитометр

Ядерно-прецессионный протонный магнитометр имеет, на первый взгляд, страшное название. На самом деле физика процессов, протекающих в магнитометре, обыденно проста.

Рис. 1. Схема протонного магнитометра:
L - катушка, создающая вспомогательное намагничивающее поле H0;
П - катушка, в которой возникает эдс, обусловленная прецессией ядерных моментов вокруг измеряемого магнитного поля Н;
У - усилитель сигнала; Ч - частотомер, градуированный в э.

Принцип работы магнитометра основан на явлении прецессии протона в магнитном поле. Если протон помещен во внешнее магнитное поле, из-за своего собственного магнитного момента, он испытает магнитный вращающий момент. Поскольку он также имеет угловой момент, этот магнитный вращающий момент приведет его (протон) к прецессии - она называется 'Лармор прецессией' и ее уровень зависит от величины внешнего магнитного поля.
Частота Лармор прецессии независима от ориентации протона и зависит только от величины внешнего поля.
Частота прецессии определяется по формуле:

F = В / 23.4875

где F - частота в Гц,
В - величина индукции внешнего магнитного поля в nT.

Чтобы измерить величину местной магнитной индукции с точностью до одного nT, необходимо измерить частоту с точностью до 0.0426 гц.
Магнитное поле Земли имеет величину индукции примерно 50 мкТ. Наименьшее значение магнитной индукции на экваторе, наибольшее на полюсах. Кроме этого, величина магнитной индукции земного поля зависит от солнечной активности, времени суток, залежей полезных ископаемых и многих других факторов.

В датчике ядерно-прецессионного магнитометра, протоны 'намагничивают' (то есть, выстраивают их магнитные моменты в одном направлении) с помощью внешнего магнитного поля возбуждения, формируемого, например, соленоидом, а затем максимально быстро отключают внешнее поле. Протоны перестраиваются в направлении магнитного поля Земли и при этом все синфазно <прецессируют>, вызывая напряжение с частотой Лармор прецессии, которая может быть измерена и использоваться для вычисления величины окружающего магнитного поля. Тот же самый соленоид, после отключения возбуждающего поля, действует как катушка датчика и подключен к чувствительному усилителю для усиления напряжения прецессии.
Вызванное напряжение протонной прецессии имеет порядок микровольт.
Поскольку прецессия протонов будет впоследствии рандомизироваться тепловыми столкновениями протонов, то полезный сигнал уменьшается по экспоненте со временем. Время зависит от специфики используемого вещества и может изменятся от одной до нескольких секунд.
Для другого измерения процесс необходимо повторить.

Наиболее простая конфигурация датчика - многовитковый соленоид, содержащий внутри вещество, богатое протонами - дистиллированная вода, керосин, бензин, дизельное топливо, органические спирты.

Магнитометристы, работавшие с протонным магнитометром ММП-203, утверждают, что в датчик заливать можно все и в любых сочетаниях.
Большинство протонных магнитометров имеют соленоидальные датчики . Эта конфигурация имеет одно преимущество и несколько больших недостатков.
Преимущество - датчик легко изготовить.
Первый недостаток - датчик является чувствительным к внешним переменным магнитным полям. Поле промышленной частоты 50 гц вызовет напряжение, которое может быть намного больше, чем полезное напряжение прецессии.
Во-вторых, соленоидальный датчик чувствителен к ориентации в магнитном поле Земли. Если поле поляризации (по оси соленоида), сонаправлено с измеряемым внешним полем, то полезное напряжение будет равно нулю. Это означает, что пользователь должен всегда убедиться в правильной ориентации соленоида для корректного измерения.
Для устранения этих недостатков применяют тороидальные датчики.
Первое - тороидальная катушка - не чувствительна к внешним переменным 'шумовым' магнитным полям.
Во-вторых, тороидальная конфигурация почти не чувствительна к ориентации. Если внешнее измеряемое магнитное поле ориентируется в наименее чувствительном направлении (в плоскости тороида), вызванное полезное напряжение только в два раза меньше, чем полезное напряжение при самой чувствительной ориентации (внешнее поле направлено по оси тороида).
Сигнал никогда не уменьшается до нуля.
Единственное неудобство тороида - это трудоемкая намотка.

Протонный магнитометр работает в двух основных режимах:

  • первый из них - режим поляризации, при котором рабочее вещество подвергается воздействию сильного магнитного поля, чтобы намагнитить (то есть, выстроить в линию) протоны.
  • Второй режим - фактическое измерение частоты прецессии для определения величины магнитного поля.

В обоих режимах используется та же самую обмотка, как для поляризации электромагнита так и для датчика напряжения прецессии.
Основная величина, которая будет измерена - частота прецессии протонов. Это переменное напряжение диапазона звуковых частот на выходе датчика. Это напряжение составляет от долей до единиц микровольт и должно быть усилено. Очевидно, что усилитель должен иметь низко шумовой фактор.

Частота прецессии должна быть измерена настолько точно - насколько возможно.
Чем точнее измерена частота прецессии, тем точнее будет определена величина магнитного поля.

Так как сигнал распадается по экспоненте со временем - период измерения ограничен.
При уменьшении амплитуды сигнала отношение сигнал-шум ухудшается.
При постройке магнитометра необходимо учитывать все эти факторы.
В магнитометре, мы хотим измерить абсолютную величину магнитного поля.
При использовании современных микроконтроллеров преобразование частоты прецессии протонов в величину индукции магнитного поля по вышеприведенной формуле легко решается.

Часть 2.

Блок-схему одного из возможных вариантов реализации квантового протонного магнитометра можно представить следующим образом:

Рассмотрим принцип работы данного устройства.
Цикл одного измерения магнитного поля состоит из следующих этапов:

  1. Поляризация.
    С Модуля микроконтроллера формируется Управляющий импульс 1 и приводит к замыканию Коммутатора К1 (далее просто К1), при этом Коммутатор К2 (далее К2) находится в разомкнутом состоянии. Через Датчик начинает протекать постоянный ток поляризации. Величина этого тока зависит от активного сопротивления датчика и составляет обычно от нескольких сот мА до нескольких А. Под воздействием созданного этим током электромагнитного поля в рабочем веществе Датчика (Подробнее строение Датчика рассмотрим позднее, а в общем он представляет собой катушку индуктивности соленоидального, тороидального или смешанного типа, в качестве "сердечника" которой выступает "рабочее вещество" - жидкость или газ, содержащее свободные протоны; часто используют дистиллированную воду, бензин, керосин или, что может быть особенно полезно в полевых условиях, спирт :) свободные протоны "выстраиваются" согласно линиям напряженности поля.

  2. Подавление переходного процесса.
    К1 размыкается, К2, как и ранее находится в разомкнутом состоянии. Этот этап при ряде условий можно было бы и не выделять отдельно, но индуктивность Датчика может быть достаточно высокой (от нескольких десятков до нескольких сотен мГн) и момент размыкания К1 может представлять опасность для высокочувствительного Малошумящего входного усилителя.

  3. Усиление сигнала с Датчика, фильтрация, преобразование в "удобочитаемую" для микроконтроллера форму, измерение частоты и перевод в нанотеслы с последующим отображением на дисплее.

  4. К1 разомкнут, К2 замкнут. При отключении поляризационного тока свободные протоны начинают перестраиваться под воздействием магнитного поля Земли и при этом совершают колебательные движения, вызывая появление на датчике напряжения с частотой, прямо пропорциональной напряженности магнитного поля. Коэффициент пропорциональности равен 23,4872 нТл/Гц, т.е. при возникновении на Датчике напряжения с частотой 2000 Гц напряженность магнитного поля равна 2000*23,4872=46974 нТл.

Сложность заключается в том, что величина напряжения лежит в диапазоне 0,5-2 мкВ (при разумных размере датчика, его индуктивности, токе поляризации и объеме рабочего вещества) и стремительно падает по экспоненциальному закону до нуля за очень небольшой промежуток времени (примерно 0,7с для керосина, 2,5-3с для дисциллированной воды).
Для получения приемлемого соотношения сигнал/шум мы должны за время около 0,3-0,4с измерить частоту напряжения (грубо для наших целей лежащую в диапазоне 1000-3000Гц) с точностью до сотых долей Гц (разрешение прибора при этом составит примерно 1 нТл).
Методы расчета и построения датчика, а также возможный метод измерения частоты с заданной точностью мы рассмотрим далее. Фильтр нужен для подавления шумовых составляющих сигнала, лежащих вне рабочего диапазона, Компаратор или триггер Шмитта - для увеличения крутизны фронтов сигнала и преобразования его в "удобочитаемую" для микроконтроллера форму (можно, конечно, использовать для этих целей и встроенный компаратор микроконтроллера).

Для наглядности рассмотрим графики:

Как видим, цикл одного измерения состоит из двух взаимосвязанных импульсов:

  • первого для управления поляризацией, а затем, через интервал времени t задержки , служащий для подавления переходного процесса в Датчике

  • второго, подключающего схемы усиления, обработки и измерения входного сигнала.

Часть 3.

Рассмотрим более подробно отдельные моменты проектирования устройства в целом.

Поляризация.

Упрощенный вариант схемы поляризации может иметь следующий вид (Рис 1): В данном варианте подача напряжения поляризации и подключение датчика к усилителю происходит при помощи реле, диоды VD1 и VD2 служат для гашения импульса самоиндукции, транзистор VT для "заземления" входа высокочувствительного усилителя и запирается лишь на время, необходимое измерительной схеме для замера частоты сигнала с датчика (во многих случаях он необязателен). Конденсатор С рез здесь и в дальнейших схемах ставится лишь в случаях использования резонансного включения датчика. Применение подобного решения нежелательно ввиду низкого быстродействия релейной коммутационной схемы и подгоранию контактов.

Этих недостатков лишена схема на Рис. 2, где функции реле выполняют транзисторы VT1 и VT2, при помощи VT2 также осуществляется задержка подключения усилителя на время, необходимое для полного подавления переходного процесса в датчике. Но и эта схема неприменима из-за того, что транзисторы являются хоть и достаточно качественными ключами, но не идеальными - в закрытом состоянии через VT1 и датчик протекает ток утечки сток-исток порядка нескольких мкА, что в нашем случае достаточно много (т. к. амплитуда измеряемого нами сигнала с датчика находится в диапазоне от десятых долей мкВ до 1-2 мкВ при нерезонансном подключении датчика).

Схема на Рис. 3 представляет собой "симбиоз" первых двух и лишена присущих им недостатков. Механизм ее работы таков: до начала поляризации транзистор VT1 закрыт, VT2 открыт, контакты реле находятся в показанном на схеме положении; при поляризации VT1 открывается и через датчик протекает ток; по окончании поляризации VT1 закрывается и через несколько мс (время, достаточное для завершения переходного процесса) реле подключает датчик к усилителю и запирается VT2; после проведения измерения контакты реле возвращаются в исходное положение и отпирается VT2. Подобная реализация предотвращает протекание тока утечки сток-исток VT1 через датчик в момент измерения, исключает коммутацию больших токов при помощи реле и может быть использована на практике (в качестве реле можно использовать, например, РЭС 55 или аналогичные). Для желающих избавиться в схеме от такого "узкого" места, как реле, можно рекомендовать вариант решения, предложенный J.A. Koehler-ом (именно его работы позволили заняться отработкой принципов построения протонного магнитометра, т. к. содержат большое количество необходимого теоретического материала и доступны в Inete, желающие ознакомиться с оригиналом могут скачать одну из его работ по адресу: http://www.thunting.com/geotech/pages/mag/info/koehler/KoehlerMag.pdf).

На Рис. 4 показана схема, не использующая реле в качестве коммутирующего элемента. Этого удалось добиться путем добавления нескольких транзисторов и некоторым усложнением управляющей схемы (при использовании микроконтроллера управление реализуемо программно, если же микроконтроллер не используется, управляющие импульсы удобно формировать при помощи таймеров типа 555). Рассмотрим принцип работы этой схемы при помощи временных диаграмм, приведенных ниже. До начала поляризации все транзисторы, кроме VT7, закрыты. VT7 открыт - вход усилителя подключен к "земле". Для начала поляризации управляющей схемой формируются Упр. импульс 1 (примерно 0,7 с для керосина) и Вспом. импульс 1, что приводит к отпиранию VT1, VT2, VT3 и VT4, через датчик протекает ток поляризации и подключается схема подавления переходного процесса на VT4 R2. VT7, как и ранее, открыт, остальные закрыты. Как видно из графиков, Упр. импульс 1 и Вспом. импульс 1 начинают формироваться одновременно, но Вспом. импульс 1 имеет большую длительность (как правило, на 10-20 мс, в зависимости от тока поляризации и индуктивности датчика) и за это дополнительное время происходит подавление импульса самоиндукции (на R2 и защитных диодах транзисторов). Сразу же после окончания Вспом. импульс 1 формируется Вспом. импульс 2 (длительность примерно 0,2-0,5 с , к критериям выбора вернемся позднее) и отпирается VT5, VT1-VT4 и VT6 закрыты , VT7, как и ранее, открыт. Собственно, в использовании VT5 и заключается "изюминка" этой схемы. Если при поляризации "корпусным" являлся нижний по схеме вывод датчика, то в процессе измерения частоты прецессии на "корпус" подключается верхний вывод. На снимаемый с датчика сигнал это не влияет, но львиная доля тока утечки СИ VT2 (от которого, собственно, мы и стремимся избавиться) протекает по цепи +U - CИ VT2 - СИ VT5 - "корпус", минуя датчик. Через 5-10 мс после начала Вспом. импульс 2 формируется Упр. импульс 2, открывается VT6 и запирается VT7. Сигнал с датчика поступает на вход усилителя. По окончании Вспом. импульс 2 оканчивается и Упр. импульс 2 и схема возвращается в исходное состояние.

Примем схему на Рис. 4 с сопутствующими ей диаграммами за основу проекта.

Попробуем теперь сформулировать требования, предъявляемые к модулю микроконтроллера.

Начнем с варианта "Максимум".
Этот вариант преследует скромную цель создания универсального микропроцессорного ядра протонного магнитометра, пригодную для работы с датчиками различной топологии и индуктивности, разными типами рабочего вещества и любыми типами поляризации (релейной либо транзисторной), резонансным или нерезонансным включением датчика, а также реализующего ряд полезных сервисных функций, облегчающих и автоматизирующих процесс поиска. Блок-схема этого модуля может выглядеть следующим образом (Рис 1):

Основными функциями этого модуля являются формирование управляющих и вспомогательных импульсов, обработка входного сигнала и вывод полученных результатов на дисплей.
Рассмотрим подробнее обработку входного сигнала и, в частности, измерение частоты входного напряжения исходя из озвученных выше условий.
Очевидно, что метод измерения "в лоб", т.е. подсчет количества импульсов в единицу времени, не проходит - точность будет очень далека от требуемой. Для получения нужных нам результатов можно, например, сделать следующим образом. Сформируем условный временной интервал, длительность которого будет равна, скажем, ста периодам частоты входного сигнала. Для частоты 1000 Гц длительность этого интервала будет равна (1/1000)*100 = 0,1 с (исходя из этого допущения можно сразу принять фиксированную длительность Вспомогательного импульса 2 равной, например, 0,3 с , что вполне удовлетворяет поставленным выше условиям для времени измерения входного сигнала; тогда минимальный предел измерения напряженности магнитного поля для нашего прибора будет составлять примерно ~10000 нТл с учетом всевозможных временных задержек).
Далее, для наглядности, предположим, что на один из двух входов логического элемента "И" подается наш условный временной интервал (зависящий от частоты входного сигнала), а на другой - сигнал с высокостабильного кварцевого генератора с фиксированной частотой, скажем, F ген =1МГц. Тогда по количеству импульсов на выходе логического элемента можно судить о частоте входного сигнала: F входн =1/((Кол-во имп./F ген )/100). Чем выше частота F ген , тем выше точность измерения частоты. Для получения результата измерения в нТл необходимо значение входной частоты в Гц умножить на коэффициент 23,4872 (и коэффициент, и значение частоты, разумеется, можно округлять, но желательно, чтобы погрешность измерения не превышала 1 нТл).

Вернемся к функциям модуля микроконтроллера и рассмотрим все предъявляемые к нему в идеале требования подробно.
Как видно из блок-схемы, управление работой и настройки осуществляются при помощи пяти кнопок. Все функции модуля микроконтроллера можно свести в два основных режима: режим работы и режим настроек.
По нажатию кнопки "Меню" прибор переходит из рабочего режима в режим настроек, повторное нажатие возвращает его в рабочий режим.
Кнопками "Влево" и "Вправо" осуществляется навигация по функциям в режиме настроек, а также просмотр результатов измерений в рабочем режиме (более подробно это будет рассмотрено ниже).
Кнопка "OK" служит для записи измененных настроечных параметров в EEPROM контроллера, входа в подменю и выхода из него, а также для проведения одиночного измерения магнитного поля в режиме работы (при выбранном ручном режиме (см. далее)) при ее кратковременном нажатии.
Кнопка "Фон" предназначена для записи результатов только что сделанного замера магнитного поля в специальную ячейку памяти, относительно которой могут проводиться дальнейшие измерения, подробнее об этом ниже.
Настроечное меню (вызывается нажатием кнопки "Меню" из рабочего режима) состоит из двух основных подменю:

  1. Рабочие настройки.
  2. Аппаратные настройки.

В рабочих настройках содержатся параметры, предназначенные для изменения пользователем в процессе полевых работ, а в аппаратных настройках - параметры, установленные изготовителем прибора и зависящие от типов датчика и рабочего вещества, методов поляризации и измерения.
Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - вход в подменю, "Меню" - выход в режим работы.
Рассмотрим каждое из подменю:

А) - Рабочие настройки. Включают в себя следующие функции:

  1. Метод работы.
  2. Метод измерений.
  3. Интервал.
  4. Диапазон.
  5. Звуковое оповещение.
  6. Контроль питания.
  7. Подсветка дисплея.

Кнопками "Влево" и "Вправо" осуществляется выбор пункта, "ОК" - вход в подменю выбранного пункта, "Меню" - выход в режим настроек.
Рассмотрим каждый из пунктов:

  1. Метод работы подменю:
    • а) Типовой (по умолчанию) (здесь и далее параметры по умолчанию заносятся в EEPROM при прошивке микроконтроллера).
    • б) Относительный.

    Эти пункты задают вид экрана и некоторые специфические функции в режиме работы.

    Для типового метода экран имеет следующий вид:

    Для относительного метода:

    Крупная надпись в нижней половине экрана - величина только что сделанного измерения магнитного поля (т. е. "последнего"). В столбцах с индексами "-1", "-2" и т.д. значения предпоследнего, предпредпоследнего и т. д. измерения соответственно. Отличия этих методов заключается в том, что для типового просто делается ряд замеров и контролируется изменение поля между только что сделанным измерением и измерением в соответствующем столбце (эта разница и есть цифры в столбцах со знаками "+" и "-"). Для относительного процедура несколько иная. Оператор выходит на местность и делает ряд пробных замеров с целью определить примерный магнитный фон. Когда, по его мнению, после очередного замера показания внизу экрана наиболее соответствуют фону, он нажимает кнопку "Фон" и это показание переносится в столбец "ФОН". Далее все как в первом варианте, с тем лишь отличием, что цифры с плюсами и минусами в столбцах "-1", "-2" соответствуют разнице между фоном и сделанным предпоследним и предпредпоследним измерением соответственно, а в столбце "ФОН" показана разница между фоном и только что сделанным измерением. Для работы при относительном методе измерений необходимо выбрать его в меню "Метод работы", выйти из режима настроек в режим работы (при этом в верхней половине экрана не будет никаких данных), сделать несколько замеров магнитного поля (результат каждого сделанного замера отражается в нижней части экрана, а при проведении последующего замера стирается и заменяется на новый), при соответствии индицируемого замера средней величине магнитного поля нажать кнопку "Фон" - это значение переносится в столбец "ФОН", вид экрана меняется на показанный выше для относительного метода и прибор готов к работе. Под хранение данных измерений (примерно 50-100 значений) желательно использовать энергонезависимую память EEPROM, чем больше их туда влезет, тем, разумеется, лучше. Просмотр результатов измерений (т. е. "прокрутка" верхней половины экрана) осуществляется в режиме работы при помощи кнопок "Влево" и "Вправо", при одновременном нажатии этих кнопок в течение нескольких секунд все сохраненные данные стираются. Это дает возможность на местности делать замеры, а дома анализировать данные и составлять магнитометрические карты. Выбор типового или относительного метода осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню рабочих настроек, "Меню" - выход в меню рабочих настроек без сохранения изменений.

  2. Метод измерений подменю:

    • а) ручной (по умолчанию).

    • б) автоматический.

    При ручном методе каждое измерение в режиме работы производится только при кратковременном нажатии кнопки "ОК" (необходимо предусмотреть блокировку этой кнопки от повторного нажатия до полного окончания цикла одного измерения (см. приведенные выше графики).
    При автоматическом прибор беспрерывно делает измерения с интервалом времени между ними, задаваемым в следующем пункте меню.
    Кнопка "ОК" в режиме работы заблокирована. Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню рабочих настроек, "Меню" - выход в меню рабочих настроек без сохранения изменений.

  3. Интервал.

    Задает значение временного интервала между циклами измерений для автоматического метода (см. приведенные выше графики). Принимает значения от 0,5 с до 5 с с шагом 0,5 с. (по умолчанию 3 с). Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню рабочих настроек, "Меню" - выход в меню рабочих настроек без сохранения изменений.

  4. Диапазон.

    Служит для переключения диапазонов измерения при использовании резонансного включения датчика (фактически для подключения разных значений емкостей между точкой соединения К2 с малошумящим входным усилителем и корпусом (см. общую блок-схему). Принимает значения от 1 до 5 (а по возможности до 8-9, для наиболее полного перекрывания возможных рабочих диапазонов)с шагом 1 (по умолчанию 1) и приводит к появлению активного логического уровня на соответствующем выводе микроконтроллера (см. блок-схему модуля микроконтроллера). При дефиците свободных портов можно использовать, например, десятичный счетчик - тогда потребуются всего два порта (один на сброс счетчика, а другой для загрузки в него последовательности из определенного количества импульсов). Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню рабочих настроек, "Меню" - выход в меню рабочих настроек без сохранения изменений.

  5. Звуковое оповещение.

    Желательно для оповещения оператора об относительно большом изменении магнитного поля между только что сделанным измерением и предыдущим (или фоновым, в зависимости от метода работы). Формирует кратковременный звуковой сигнал, если модуль разницы вышеуказанных значений превышает установленный порог. Принимает значения от Выкл. (оповещение отключено) (по умолчанию) до 500 нТл (установка модуля порога) с шагом 50 нТл. Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню рабочих настроек, "Меню" - выход в меню рабочих настроек без сохранения изменений.

  6. Контроль питания.

    Индицирует текущее напряжение питания. "ОК" или "Меню" - выход в меню рабочих настроек.

  7. Подсветка.

    Включает и выключает подсветку дисплея. Принимает значения Вкл. и Выкл. (по умолчанию). Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню рабочих настроек, "Меню" - выход в меню рабочих настроек без сохранения изменений.

Б) - Аппаратные настройки. Включают в себя следующие функции:

  1. Время поляризации.

  2. Время подавления переходного процесса.

  3. Задержка подключения усилителя.

  4. Входная задержка.

  5. Порог разряда аккумулятора.

Кнопками "Влево" и "Вправо" осуществляется выбор пункта, "ОК" - вход в подменю выбранного пункта, "Меню" - выход в режим настроек.

Рассмотрим каждый из пунктов:

  1. Время поляризации.

    Задает значение длительности импульса поляризации (см. приведенные выше графики). Изменение этого параметра необходимо для обеспечения работоспособности прибора с разными типами рабочего вещества в датчике (например, для керосина это значение составляет 0,6-0,7 с, а для дисциллированной воды - 2,5-2,8 с). Принимает значения от 0,2 с до 3 с с шагом 0,2 с. (по умолчанию 0,7 с). Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню аппаратных настроек, "Меню" - выход в меню аппаратных настроек без сохранения изменений.

  2. Время подавления переходного процесса.

    Задает величину временного интервала, на которую Вспомогательный импульс 1 больше Управляющего импульса 1 (см. приведенные выше графики). Служит для адаптации устройства под датчики различных топологий, индуктивностей и с различными активными сопротивлениями. Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню аппаратных настроек, "Меню" - выход в меню аппаратных настроек без сохранения изменений.

  3. Задержка подключения усилителя.

    Задает величину, на которую Управляющий импульс 2 отстает от Вспомогательного импульса 2 (см. приведенные выше графики). Может понадобиться при использовании различных методов поляризации. Принимает значения от 3 мс до 30 мс с шагом 3 мс (по умолчанию 9 мс). Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню аппаратных настроек, "Меню" - выход в меню аппаратных настроек без сохранения изменений.

  4. Входная задержка.

    Задает величину временного интервала между началом Управляющего импульса 2 и переходом входа микроконтроллера в режим счета входных импульсов (на которую вход микроконтроллера "запаздывает", вообще же микроконтроллер выходит из режима подсчета входных импульсов одновременно с окончанием Вспомогательного импульса 2 и Управляющего импульса 2 и находится в режиме счета как минимум 0,3 с - 30 мс - 50 мс = 0,22 с, что соответствует нижнему диапазону измерения (при подсчете длительности ста входных импульсов (1/(0,22/100)) *23,4872 = ~ 10600 нТл). Может потребоваться для установления усилительно-фильтрующей схемы в линейное состояние, особенно при использовании резонансного метода включения датчика. Принимает значения от 0 мс до 50 мс с шагом 5 мс (по умолчанию 20 мс). Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню аппаратных настроек, "Меню" - выход в меню аппаратных настроек без сохранения изменений.

  5. Порог разряда аккумулятора.

    Устанавливает значение порога разряда элементов питания, по достижению которого прибор оповещает об этом оператора в произвольной форме. Принимает значения от 8 В до 18 В с шагом 0,5 В (по умолчанию 11 В). Выбор значения осуществляется кнопками "Влево" и "Вправо", "ОК" - сохранение выбранного значения в EEPROM и выход в меню аппаратных настроек, "Меню" - выход в меню аппаратных настроек без сохранения изменений.

В режиме работы желательно предусмотреть некоторую сервисную индикацию:

  • "Нет сигнала" - при отсутствии подсчитываемых импульсов на входе микроконтроллера за интервал измерения.

  • "Превышение предела" - при расчетном значении напряженности более 99999 нТл.

  • "Принижение предела" - при количестве счетных импульсов за интервал измерения менее 100.

Подобный вид отображения информации и обилие настроек вызваны желанием получить не только высокофункциональное универсальное цифровое ядро протонного магнитометра, но и инструмент для проведения экспериментов с разными типами датчиков и рабочего вещества.
При возникновении трудностей с реализацией всего этого задачу можно серьезно упростить:

  • Полностью исключить систему меню,

  • убрать функцию хранения в памяти результатов измерений,

  • использовать любой подходящий знакосинтезирующий ЖКИ с отображением единственного значения последнего сделанного измерения.

Желательно сохранить:

  • возможность работы в ручном или автоматическом режимах (интервал между измерениями 2-3 с, переключение режимов при помощи тумблера).

  • Временные константы - те, которые "по умолчанию", с возможностью корректировки при перешивке контроллера.

Хотелось бы сказать несколько слов об использовании резонансного или нерезонансного метода включения датчика. И тот, и другой метод имеет свои плюсы и минусы.
При нерезонансном включении мы имеем широкую полосу пропускания (т. е. большой диапазон измеряемых значений напряженности магнитного поля), но более низкий уровень сигнала на входе усилителя).
При резонансном же включении наоборот - уровень сигнала выше, но диапазон определяется добротностью LC контура, состоящего из датчика и C рез . Практически при использовании резонансного метода датчик может иметь меньшие габариты и вес, но для обеспечения широкого рабочего диапазона потребуются несколько переключаемых резонансных емкостей.
При использовании микроконтроллера можно, например, сделать следующим образом: после поляризации и подавления переходного процесса в датчике к нему поочереди подключаются на короткое время несколько (до десятка) конденсаторов разной, заранее рассчитанной из условия перекрывания всего необходимого диапазона частот, емкости. Для каждой подключенной емкости микроконтроллер делает измерение уровня сигнала на выходе усилителя, запоминает, при подключении какой емкости это уровень был максимальным, а затем делает "основное" измерение частоты при использовании этой емкости.
Основные вопросы, работы магнитометра, рассмотрены.
Буду, признателен за уточнения и исправление неточностей, если таковые допустил.