Magnetism topics on this page include:

Magnetic Levitation Mk I

Magnetic Levitation Mk II

Magnetic Levitation of a coil

Levitation with magnetic induction

Diamagnetic levitation

Levitron

Magnetic levitation Mk I 2004
I am working on potential exhibits for the Gravity Discovery Centre in Gingin, Western Australia, as part of an 'antigravity' display. The GDC is the public interface for the Australian International Gravitational Observatory which is part of a worldwide effort to detect elusive gravity waves.

It works! (After a week of adjusting and testing) A NIB magnet with some metal pipe is supported motionless, 1 inch below the coil. "..look Ma, no hands.."
The circuit uses two linear Hall effect devices at either end of an electromagnet. The circuit senses a difference in the two outputs which should cancel regardless if the coil is switched on or off. An approaching magnet disturbs this balance and this this output is fed to a PWM (pulse width modulated) supply for the MOSFET output to the coil. Conditions are set so that there is an equilibrium is setup with the weight of the magnet and the electromagnet at a certain point where it will hover. Hmmm.. magnetism opposing gravity - sounds like 'antigravity' to me...

The left photo shows the coil and earlier circuit board. The other two are of the neat side and the not-so-neat side. Alright, so I don't know how to do PCB's.

The coil will draw 10 A at 13V and is wound on an old solder bobbin. In operation, however, the draw is less than 2 A at 12 V. The drive circuit uses three LM324 quad op amps (of which 9 of the 12 are used) and a dual 555 timer (NE556). This drives a IRFP450 MOSFET rated at 500V 14A under the CPU cooler fan. There are two BYV29 500 V, 9 A, 60 nS diodes to absorb the back EMF when the coil switches off. The circuit comes from Rick Hoadley's excellent magnet site. I have made only minor modifications including reducing minimum pulse width from 4 to 1 uS and using the MOSFET instead of an IGBT.

This is a standard 200 W ATX computer power supply which is 7 years old. It supplies +12 V 8 A (yellow wire), -12 V (blue) and +5 V (red). It has been modified to include a power switch on the back panel and a divider across the 5 V line with a 24 ohm and a 10 ohm resistor in series. This allows some load for the 5 V line (? need 0.1 A) plus a 3.3 V reference for the orange lead which normally senses the computer board voltage of 3.3 V. I did blow out the first supply I used but no problems since this modification which also powers the LED through a 100 ohm resistor from the 3.3V line. I have tidied up the leads into one multicore cable terminating in a 25 pin plug.

In action with a fancy mount and fitted into a suspended PVC pipe with all the wires tidied up, it can support a dish with 110 g of sweets. (This was for a lunchtime demo). It worked OK but unfortunately I left it running inadvertently for some time and the electromagnet melted through the end cap. Ooops. Remarkably the Hall device and the electronics were unharmed.

Magnetic Levitation Mk II 2004
Now time for a serious coil. This was made from an x-ray ballast transformer. The rectangular core was taken apart and changed to a solenoid core with enlarged ends. Fortunately the laminations weren't fixed and were suitable to do this. The iron core at 4 x 4 x 17 cm has about 20 times the volume as the previous coil and with the much higher number of windings, gives a much more efficient coil. It runs at 60 V at 1 amp (= 60 W) at rest supporting a NIB magnet 3 inches (8 cm) below the electromagnet coil. At full power it draws 40 V 6 A (= 240 W). This power is supplied from a separate mains transformer. Total weight is 10 pounds (4 kg). Total levitating lifting power is around 2 pounds (1 kg) but it will be supporting a NIB magnet weighing 160g measuring 1.3 inches (3 cm) diameter x 1.3 inches (3 cm) deep.

Mounted on the coil are the two Hall effect devices (one end is shown on the right connected to shielded cable). There is a thermal cutout not shown (microwave ovens have lots of these rated at 145 - 160 degrees C). Also not well shown are a 0.22 uF 250 V polyester capacitor and a freewheeling BYV29 500 V, 9 A, 60 nS diode and heatsink to constrain the RF hash locally.

This shows the mounting inside a 12 inch (30 cm) acrylic sphere, with a high flow centrifugal fan supplying airflow through the PVC above it. Without the copper block beneath it, the magnet tends to oscillate and become unstable after perhaps 10 seconds or so. Despite my best efforts to counter this electronically, the most effective way to dampen it is to have a heavy aluminium or copper block beneath it about 1 inch (2-3 cm). This still gives an effective display and you can spin the NIB magnet or have it completely in your hand still levitated and resisting being moved away. Giving the magnet a simple spin with the fingers will keep it rotating for 1 1/2 hours limited by friction and eddy currents. It will also support an iron object such as a spanner without a magnet as above.

(Video 625k MPEG - run mouse over to play)

The control electronics are essentially the same but I now use two paralleled MOSFET's on a larger heat sink for extra power handling. The single control is for control of power and hence position.

The magnetic levitation demonstrated by Sylvia at the GDS. This (the mag-lev, not Sylvia) has been on constant hands on public display since November 2004 and no-one has pinched the magnet yet. The alarm that sounds as the magnet is pulled away helps....

Links
Rick Hoadleys article and links on suspended objects
Adam Kumpf's project with mathematical descriptions of the instability and the simple correction for this.
cjk2 from the 4HV forum with another maglev circuit which is simpler.

Magnetic levitation of a coil 2006
Here is an air cored coil out of a defibrillator output circuit. Don't know number of turns but the inductance is 10mH (I think). It is drawing 6.5 A at 100V AC to get the lift of about 1/2 inch off a 1/4 inch copper plate. It is tethered like a conventional lifter. The power is over 600 W so gets hot quickly.

The left photo shows the coil levitating above the copper plate. The middle photo shows the 284 g coil lifting a 217 g solder reel (total 500 g). Current was a bit higher and distance off the base was 1/4 inch compared with 1/2 inch before. The right photo with the clamp meter shows the current of 6.5 A.

Above, left photo shows voltage across coil of 100.6 V, middle photo shows current of 6.61 A (giving 665 VA) and the right photo shows true RMS power of 0.55 kW (550 W). I presume this is a power factor of 0.82.

Above, left photo shows double coils elevating with only 2 support wires plus the effect of a large iron mass beneath it (none as it is greater than the skin depth in copper of about 5 mm at 50 Hz). The right photo shows the setup of the two coils and true RMS power of 1.3 kW.

I did try levitating a MOT with the E section opened and facing down but really needed a better winding. Hence I tried a non cored coil.

Levitation with magnetic induction 2006
I have cut down a large transformer to allow an external field. It was 240 V to 110 V and rated at 2 kVA. I use the two windings in series. When run from DC it draws 15 A at 30 V or 450 W. This is enough to levitate a large NIB magnet about 17 cm away. This compares with a maximum of about 10 cm for the maglev unit above.

Above, left photo shows the cut down transformer. The middle photo shows an aluminium disc in place, and the right photo shows the disc being levitated. The central drinking straw is to stop the disc sliding off the field. It will spin freely.

Diamagnetic levitation 2004
A classical setup with a small cube magnet between two Bismuth plates. A large magnet well above provides the lift and a fairly uniform field and the Bismuth plates help stabilize the area locally. Without the diamagnetic repulsion (or other tricks), Earnshaw's theorem states that this cannot be stable. Note that this is permanent levitation without external power as used above.

The magnet rotates freely and is quite stable in the centre. I have used 3 small Bismuth cylinders as below for levitation of a small cubic NIB magnet. I have also used about 200g of Bismuth as 19 small cylindrical pellets in rows above and 19 below for large magnets but to levitate successfully the field needs to be uniform and the main lifting magnet needs to be larger and further away. They are fixed firmly with ... tape.

The left photo shows the display setup with large bismuth plates and the right photo shows the closeup of the smaller but easier to see single bismuth cylinders.

The left photo above shows a 10 g bismuth cylinder showing a weight (with support block) of 38.96 g. The right photo shows that this reduces to 38.57 g in the electromagnet field. This is a 0.39 g or 3.9% reduction in the weight of the bismuth. It is not well optimized though. Hardly levitation as the field is not strong and also does not have a strong gradient.

The left photo above shows the 10 g bismuth cylinder with a weight (with support beam) of 24.38 g. The right photo shows that this reduces to 24.16 g in the NIB magnet field. This is a 0.22 g or 2.2 % reduction. With the same magnet one can elevate a thin sheet of pyrolytic graphite which is the most diamagnetic stuff around. Unfortunately I don't have any to show.

Levitron 2005
The Levitron (R) is a small spinning top like magnet that is fully hovering in mid air unsupported. It is rather critical in its dimensions and operation and is adjusted by very small weight changes. It is commercially made and sold as a toy. See their site for details.

I have tried to make, one unsuccessfully as yet, with the arrangement below.

Here the magnet is supported in a stable position just above equilibrium. Any lower and it will fall over. If it is spinning and all parameters are correct it would hover in the air until it slowed sufficiently.

I have used a motor to spin it to find a zero balance position but haven't really spent a lot of time on it. Arranging a stable spin as a simple top is the first challenge due to the multiple components (nylon nuts and bolt, acrylic disc and toroidal magnet. I have used a nylon screw but it is very hard to machine as it bends and slips. Probably machining one from something hard like polycarbonate would be better and mean there is only one shaft, disc and magnet support and symmetry is more assured.

Meissner effect levitation on a track http://www.youtube.com/watch?v=CQ70tayKZh8

Simple Meissner levitation http://www.youtube.com/watch?v=pO2eDJBr50E